summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarsten Loesing <karsten.loesing@gmx.net>2009-07-15 16:32:40 +0200
committerKarsten Loesing <karsten.loesing@gmx.net>2009-07-15 16:32:40 +0200
commit8c496d1660c326c0bc2bd5c505255d5ec3b653ec (patch)
tree4cab68d08f3ae7f4b9dbc8c12be028b0139791a1 /configure.in
parent416940d93bac49f78b57a2cf561bd324d75b391f (diff)
downloadtor-8c496d1660c326c0bc2bd5c505255d5ec3b653ec.tar.gz
tor-8c496d1660c326c0bc2bd5c505255d5ec3b653ec.zip
Some tweaks to statistics.
Changes to directory request statistics: - Rename GEOIP statistics to DIRREQ statistics, because they now include more than only GeoIP-based statistics, whereas other statistics are GeoIP-dependent, too. - Rename output file from geoip-stats to dirreq-stats. - Add new config option DirReqStatistics that is required to measure directory request statistics. - Clean up ChangeLog. Also ensure that entry guards statistics have access to a local GeoIP database.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 0f6ed80657..ab7d6480cf 100644
--- a/configure.in
+++ b/configure.in
@@ -92,11 +92,11 @@ if test "$enable_exit_stats" = "yes"; then
AC_DEFINE(ENABLE_EXIT_STATS, 1, [Defined if we try to collect per-port statistics on exits])
fi
-AC_ARG_ENABLE(geoip-stats,
- AS_HELP_STRING(--enable-geoip-stats, enable code for directories to collect per-country statistics))
+AC_ARG_ENABLE(dirreq-stats,
+ AS_HELP_STRING(--enable-dirreq-stats, enable code for directories to collect per-country statistics))
-if test "$enable_geoip_stats" = "yes"; then
- AC_DEFINE(ENABLE_GEOIP_STATS, 1, [Defined if we try to collect per-country statistics])
+if test "$enable_dirreq_stats" = "yes"; then
+ AC_DEFINE(ENABLE_DIRREQ_STATS, 1, [Defined if we try to collect per-country statistics])
fi
AC_ARG_ENABLE(buffer-stats,