summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-05-11 15:52:36 -0400
committerNick Mathewson <nickm@torproject.org>2012-05-11 15:52:36 -0400
commite6dbe693b7fd90a495b98ec790205ff4ac56fea9 (patch)
tree860b1efc42b04830bed8ba221c8598b1b73050bc /configure.in
parente36cd016337f26188f572e0bd511a4f8b72c07dc (diff)
downloadtor-e6dbe693b7fd90a495b98ec790205ff4ac56fea9.tar.gz
tor-e6dbe693b7fd90a495b98ec790205ff4ac56fea9.zip
Make the option-checker code work with osx clang
This is a matter of making gcc and friends squirm more loudly when they get an option they don't like (-pedantic) and making clang shut up with it gets an option it tolerates but doesnt know (-Qunknown-argument). Is there no better way?
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d894c73df8..3e645753ee 100644
--- a/configure.in
+++ b/configure.in
@@ -173,6 +173,7 @@ AM_PROG_CC_C_O
if test x$enable_gcc_hardening != xno; then
CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
+ TOR_CHECK_CFLAGS(-Qunused-arguments)
TOR_CHECK_CFLAGS(-fstack-protector-all)
TOR_CHECK_CFLAGS(-Wstack-protector)
TOR_CHECK_CFLAGS(-fwrapv)