summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-05-14 13:46:37 -0400
committerNick Mathewson <nickm@torproject.org>2012-05-14 13:46:37 -0400
commit21e32619146db4602bc35acd0f237a91b43fd754 (patch)
treeb3ac39093694a92adbaa57009391932967c1ae01 /configure.in
parent9ffccb3f49e1c73b34c0bd41fd3bc7116afab4b7 (diff)
downloadtor-21e32619146db4602bc35acd0f237a91b43fd754.tar.gz
tor-21e32619146db4602bc35acd0f237a91b43fd754.zip
Bump _WIN32_WINNT to 0x0501 throughout the code
This tells the windows headers to give us definitions that didn't exist before XP -- like the ones that we need for IPv6 support. See bug #5861. We didn't run into this issue with mingw, since mingw doesn't respect _WIN32_WINNT as well as it should for some of its definitions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 92b7acbeba..43c9bb2a5e 100644
--- a/configure.in
+++ b/configure.in
@@ -796,7 +796,7 @@ AC_CHECK_TYPES([struct in6_addr, struct sockaddr_in6, sa_family_t], , ,
#include <sys/socket.h>
#endif
#ifdef _WIN32
-#define _WIN32_WINNT 0x400
+#define _WIN32_WINNT 0x0501
#define WIN32_LEAN_AND_MEAN
#if defined(_MSC_VER) && (_MSC_VER < 1300)
#include <winsock.h>
@@ -820,7 +820,7 @@ AC_CHECK_MEMBERS([struct in6_addr.s6_addr32, struct in6_addr.s6_addr16, struct s
#include <sys/socket.h>
#endif
#ifdef _WIN32
-#define _WIN32_WINNT 0x400
+#define _WIN32_WINNT 0x0501
#define WIN32_LEAN_AND_MEAN
#if defined(_MSC_VER) && (_MSC_VER < 1300)
#include <winsock.h>