summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-02-12 21:06:06 +0000
committerNick Mathewson <nickm@torproject.org>2005-02-12 21:06:06 +0000
commit5ca04cbf569a1435713d2f368528ebe207dd94d0 (patch)
tree6c51ce52bbe3b76e560c70c1fb98f854f0c1fb07 /configure.in
parentf6221b695f43a3fc3daa5629e2de95a6189c9810 (diff)
downloadtor-5ca04cbf569a1435713d2f368528ebe207dd94d0.tar.gz
tor-5ca04cbf569a1435713d2f368528ebe207dd94d0.zip
Give a better error message when zlib.h is not found.
svn:r3618
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 57489cae06..ce4afff6b2 100644
--- a/configure.in
+++ b/configure.in
@@ -141,10 +141,12 @@ AC_SYS_LARGEFILE
dnl The warning message here is no longer strictly accurate.
-AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h sys/stat.h sys/types.h fcntl.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h time.h pwd.h grp.h zlib.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
+AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h sys/stat.h sys/types.h fcntl.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h time.h pwd.h grp.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
AC_CHECK_HEADERS(event.h, , AC_MSG_ERROR(Libevent header (event.h) not found. Tor requires libevent to build.))
+AC_CHECK_HEADERS(zlib.h, , AC_MSG_ERROR(Zlib header (zlib.h) not found. Tor requires zlib to build. You may need to install a zlib development package.))
+
dnl These headers are not essential
AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h pthread.h)