summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2011-01-12 13:05:19 -0500
committerNick Mathewson <nickm@torproject.org>2011-01-12 13:05:19 -0500
commita84c6e86fe3e739a21094cf1e02dd5d7d54056e4 (patch)
tree55146c22802ab6be5d22f35fe4394e98b9f24e90 /configure.in
parent71d786b2d353715031cd3c3ef2dd7fc46b44489b (diff)
parenta2c41aa3e84ba697cc14b4b2345d8e3467cd22ac (diff)
downloadtor-a84c6e86fe3e739a21094cf1e02dd5d7d54056e4.tar.gz
tor-a84c6e86fe3e739a21094cf1e02dd5d7d54056e4.zip
Merge remote branch 'origin/maint-0.2.2'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be1ee33ca2..eddab6707b 100644
--- a/configure.in
+++ b/configure.in
@@ -784,6 +784,23 @@ if test "$tor_cv_time_t_signed" != no; then
[Define to 1 iff time_t is signed])
fi
+AC_CACHE_CHECK([whether size_t is signed], tor_cv_size_t_signed, [
+AC_RUN_IFELSE([AC_LANG_SOURCE([
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+int main(int c, char**v) { if (((size_t)-1)<0) return 1; else return 0; }])],
+ tor_cv_size_t_signed=no, tor_cv_size_t_signed=yes, tor_cv_size_t_signed=cross)
+])
+
+if test "$tor_cv_size_t_signed" = cross; then
+ AC_MSG_NOTICE([Cross compiling: assuming that size_t is not signed.])
+fi
+
+if test "$tor_cv_size_t_signed" = yes; then
+ AC_MSG_ERROR([You have a signed size_t; that's grossly nonconformant.])
+fi
+
AC_CHECK_SIZEOF(socklen_t, , [AC_INCLUDES_DEFAULT()
#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>