summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJacob Appelbaum <jacob@appelbaum.net>2009-11-14 16:43:22 -0500
committerNick Mathewson <nickm@torproject.org>2009-11-14 16:45:14 -0500
commit6f1fe7e941b8f6d62829852059862b00beed5a6e (patch)
treec5e323633933e3f93233ab8863f18c1f4e607853 /configure.in
parent22f674fcb88411d8b56a3423fb0c09bb7745529c (diff)
downloadtor-6f1fe7e941b8f6d62829852059862b00beed5a6e.tar.gz
tor-6f1fe7e941b8f6d62829852059862b00beed5a6e.zip
Fix compilation with with bionic libc.
This fixes bug 1147: bionic doesn't have an actual implementation of mlockall(); mlockall() is merely in the headers but not actually in the library. This prevents Tor compilation with the bionic libc for Android handsets.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7ffa578d69..32f28b5661 100644
--- a/configure.in
+++ b/configure.in
@@ -628,6 +628,11 @@ if test x$tcmalloc = xyes ; then
LDFLAGS="-ltcmalloc $LDFLAGS"
fi
+# By default, we're going to assume we don't have mlockall()
+# bionic and other platforms have various broken mlockall subsystems
+# some of systems don't have a working mlockall, some aren't linkable
+AC_CHECK_FUNCS(mlockall)
+
# Allow user to specify an alternate syslog facility
AC_ARG_WITH(syslog-facility,
[ --with-syslog-facility=LOG syslog facility to use (default=LOG_DAEMON)],