summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSteven Murdoch <Steven.Murdoch@cl.cam.ac.uk>2011-08-18 18:42:02 +0100
committerSteven Murdoch <Steven.Murdoch@cl.cam.ac.uk>2011-08-18 18:42:02 +0100
commitcc5b6d6cee607bbafbfd512986b2eea9c7c2c5ec (patch)
treeaf5d4414ca9a278182151ad8f7401de109367d51 /configure.in
parent7d015c886a3fc985ab767de01811d1591f0ac86a (diff)
parent52e36feda153e70cd08d624df73035b7e59a95ef (diff)
downloadtor-cc5b6d6cee607bbafbfd512986b2eea9c7c2c5ec.tar.gz
tor-cc5b6d6cee607bbafbfd512986b2eea9c7c2c5ec.zip
Merge remote branch 'origin/master' into bug2046
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f111355485..16d0930c02 100644
--- a/configure.in
+++ b/configure.in
@@ -438,7 +438,7 @@ int x = 1;
AC_MSG_CHECKING([whether Libevent is new enough for bufferevents])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <event2/event.h>
-#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 0x02000800
+#if !defined(LIBEVENT_VERSION_NUMBER) || LIBEVENT_VERSION_NUMBER < 0x02000d00
#error
int x = y(zz);
#else
@@ -446,7 +446,7 @@ int x = 1;
#endif
])], [ AC_MSG_RESULT([yes]) ],
[ AC_MSG_RESULT([no])
- AC_MSG_ERROR([Libevent does not seem new enough to support bufferevents. We require 2.0.8-rc or later]) ] )
+ AC_MSG_ERROR([Libevent does not seem new enough to support bufferevents. We require 2.0.13-stable or later]) ] )
fi
fi
fi
@@ -1123,6 +1123,15 @@ else
enable_gcc_warnings_advisory=no
fi
+# OS X Lion started deprecating the system openssl. Let's just disable
+# all deprecation warnings on OS X.
+case "$host_os" in
+
+ darwin*)
+ CFLAGS="$CFLAGS -Wno-deprecated-declarations"
+ ;;
+esac
+
# Add some more warnings which we use in development but not in the
# released versions. (Some relevant gcc versions can't handle these.)
if test x$enable_gcc_warnings = xyes || test x$enable_gcc_warnings_advisory = xyes; then