summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2011-02-03 14:21:14 -0500
committerNick Mathewson <nickm@torproject.org>2011-02-03 14:21:14 -0500
commita6c811313af3cfda1fca1d7595e9259f51d6ffd0 (patch)
tree4e2e294fdcd8db9400f3063d7bce52b09cab8ac9 /configure.in
parentcb9ac0336d0acd935aa45dfc89f02594551a24da (diff)
parentf9e251ccf8c72dadf55b51ba9695d8dd5ef6d6f1 (diff)
downloadtor-a6c811313af3cfda1fca1d7595e9259f51d6ffd0.tar.gz
tor-a6c811313af3cfda1fca1d7595e9259f51d6ffd0.zip
Merge remote branch 'origin/maint-0.2.2'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index eddab6707b..2669511430 100644
--- a/configure.in
+++ b/configure.in
@@ -1051,6 +1051,20 @@ AC_SUBST(BINDIR)
LOCALSTATEDIR=`eval echo $localstatedir`
AC_SUBST(LOCALSTATEDIR)
+if test "$bwin32" = true; then
+ # Test if the linker supports the --nxcompat and --dynamicbase options
+ # for Windows
+ save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="-Wl,--nxcompat -Wl,--dynamicbase"
+ AC_MSG_CHECKING([whether the linker supports DllCharacteristics])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([])],
+ [AC_MSG_RESULT([yes])]
+ [save_LDFLAGS="$save_LDFLAGS $LDFLAGS"],
+ [AC_MSG_RESULT([no])]
+ )
+ LDFLAGS="$save_LDFLAGS"
+fi
+
# Set CFLAGS _after_ all the above checks, since our warnings are stricter
# than autoconf's macros like.
if test "$GCC" = yes; then