summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-05-16 14:31:36 -0400
committerNick Mathewson <nickm@torproject.org>2012-05-16 14:34:17 -0400
commitf35271bf3eceadd03bff26d34c1d020892d6c6f0 (patch)
treea74fad3643e97a71fdb5325d7d47d853dbb030b0 /configure.in
parent75fc4dbbcabaedc715f0f9e883ccab1c9634e787 (diff)
downloadtor-f35271bf3eceadd03bff26d34c1d020892d6c6f0.tar.gz
tor-f35271bf3eceadd03bff26d34c1d020892d6c6f0.zip
Fix some more FreeBSD4 issues (based on a patch from grarpamp)
Apparently, freebsd 4 doesn't like malloc.h, needs sys/param.h for MIN/MAX, and doesn't have a SIZE_MAX. For bug 3894.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 424cccb874..df4c6f62b2 100644
--- a/configure.in
+++ b/configure.in
@@ -417,6 +417,8 @@ dnl These headers are not essential
AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h limits.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h inttypes.h utime.h sys/utime.h sys/mman.h netinet/in6.h malloc.h sys/syslimits.h malloc/malloc.h linux/types.h sys/file.h malloc_np.h sys/prctl.h)
+AC_CHECK_HEADERS(sys/param.h)
+
TOR_CHECK_PROTOTYPE(malloc_good_size, HAVE_MALLOC_GOOD_SIZE_PROTOTYPE,
[#ifdef HAVE_MALLOC_H
#include <malloc.h>