summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-08-15 19:26:53 -0400
committerNick Mathewson <nickm@torproject.org>2012-08-15 19:26:53 -0400
commit6a33c33a12f3af414e97b91d5718ea16f2d26673 (patch)
treea5f4dcd8da4e27ba463fc88b6bcbfb1da0934dd3 /configure.in
parent91b52a259a271df7ceeea6d8bf7adbd4d7e15a6c (diff)
downloadtor-6a33c33a12f3af414e97b91d5718ea16f2d26673.tar.gz
tor-6a33c33a12f3af414e97b91d5718ea16f2d26673.zip
Fix warnings and 64-bit problems in openbsd-malloc code
The warning fixes are: - Only define issetugid if it's missing. - Explicitly ignore the return value of writev. - Explicitly cast the retval of readlink() to int. The 64-bit problems are related to just storing a size_t in an int. Not cool! Use a size_t instead. Fix for bug 6379. Bugfix on 0.2.0.20-rc, which introduced openbsd-malloc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1db7d08e20..8aa90f6414 100644
--- a/configure.in
+++ b/configure.in
@@ -300,6 +300,7 @@ AC_CHECK_FUNCS(
gmtime_r \
inet_aton \
ioctl \
+ issetugid \
localtime_r \
lround \
memmem \