summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-09-02 05:33:11 +0000
committerNick Mathewson <nickm@torproject.org>2006-09-02 05:33:11 +0000
commit7cd08b2ccac50d1f37ca6e1dca75eda5f9d556b7 (patch)
tree2c67279c040bd23974bcf444d5ac6402ed622b3c /configure.in
parentc57f79fba104914e996eff6f92ca6fd3d418ad70 (diff)
downloadtor-7cd08b2ccac50d1f37ca6e1dca75eda5f9d556b7.tar.gz
tor-7cd08b2ccac50d1f37ca6e1dca75eda5f9d556b7.zip
r8704@Kushana: nickm | 2006-09-02 01:32:34 -0400
correct includes for net/if.h and net/pfvar.h on openbsd (from Tup) svn:r8316
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 66390b641b..4bb992191c 100644
--- a/configure.in
+++ b/configure.in
@@ -368,12 +368,21 @@ dnl These headers are not essential
AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h limits.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h stddef.h inttypes.h utime.h sys/utime.h sys/mman.h alloca.h)
AC_CHECK_HEADERS(net/if.h, [net_if_found=1], [net_if_found=0],
-[#ifdef HAVE_SYS_SOCKET_H
+[#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>
#endif])
AC_CHECK_HEADERS(net/pfvar.h, [net_pfvar_found=1], [net_pfvar_found=0],
-[#ifdef HAVE_SYS_SOCKET_H
+[#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>
+#endif
+#ifdef HAVE_NET_IF_H
+#include <net/if.h>
#endif])
AC_CHECK_HEADERS(linux/netfilter_ipv4.h,
[linux_netfilter_ipv4=1], [linux_netfilter_ipv4=0],