summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2010-05-07 23:10:30 +0200
committerLinus Nordberg <linus@nordberg.se>2010-05-07 23:10:30 +0200
commitb7e533c1d7f9af334158b324ff61bcdcb3ed2bb7 (patch)
treeb643d23c8520033b7e9fd658e71cf42cbfa78390 /configure.in
parent8ba00e4305fe87c540c452271bc6f5c461738777 (diff)
downloadtor-b7e533c1d7f9af334158b324ff61bcdcb3ed2bb7.tar.gz
tor-b7e533c1d7f9af334158b324ff61bcdcb3ed2bb7.zip
Don't be bashistic.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 07b3ff423b..dea2b5f0f1 100644
--- a/configure.in
+++ b/configure.in
@@ -98,9 +98,9 @@ AC_ARG_ENABLE(gcc-hardening,
AS_HELP_STRING(--enable-gcc-hardening, enable compiler security checks),
[if test x$enableval = xyes; then
CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector-all"
- CFLAGS+=" -fwrapv -fPIE -Wstack-protector -Wformat -Wformat-security"
- CFLAGS+=" -Wpointer-sign"
- LDFLAGS+=" -pie"
+ CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector -Wformat -Wformat-security"
+ CFLAGS="$CFLAGS -Wpointer-sign"
+ LDFLAGS="$LDFLAGS -pie"
fi])
dnl Linker hardening options
@@ -108,7 +108,7 @@ dnl Currently these options are ELF specific - you can't use this with MacOSX
AC_ARG_ENABLE(linker-hardening,
AS_HELP_STRING(--enable-linker-hardening, enable linker security fixups),
[if test x$enableval = xyes; then
- LDFLAGS+=" -z relro -z now"
+ LDFLAGS="$LDFLAGS -z relro -z now"
fi])
AC_ARG_ENABLE(local-appdata,