summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-01-13 00:20:44 +0000
committerNick Mathewson <nickm@torproject.org>2008-01-13 00:20:44 +0000
commitae6df065ed699278db5a219650cd0037dac2adec (patch)
tree38c25fd96cd82ab80819341d9434eaa65ab45282 /configure.in
parent1b4ef78f6a7f2596c7a19aa5226c46430af33338 (diff)
downloadtor-ae6df065ed699278db5a219650cd0037dac2adec.tar.gz
tor-ae6df065ed699278db5a219650cd0037dac2adec.zip
r15890@tombo: nickm | 2008-01-12 17:19:51 -0500
Add a --disable-buffer-freelists configure argument to build without buffer RAM chunk freelists, so we can benchmark the impact of this. svn:r13121
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3244cecde7..c6dc7ea503 100644
--- a/configure.in
+++ b/configure.in
@@ -34,13 +34,20 @@ AC_ARG_ENABLE(iphone,
CFLAGS="$CFLAGS -D__DARWIN_UNIX03 -DIPHONE"
fi])
+#XXXX020 We should make these enabled or not, before 0.2.0.x-final
AC_ARG_ENABLE(cell-pool,
AS_HELP_STRING(--disable-cell-pool, disable pool allocator for cells))
+AC_ARG_ENABLE(buf-freelists,
+ AS_HELP_STRING(--disable-buf-freelists, disable freelists for buffer RAM))
if test x$enable_cell_pool != xno; then
AC_DEFINE(ENABLE_CELL_POOL, 1,
[Defined if we try to use the pool allocator for queued cells])
fi
+if test x$enable_buf_freelists != xno; then
+ AC_DEFINE(ENABLE_BUF_FREELISTS, 1,
+ [Defined if we try to use freelists for buffer RAM chunks])
+fi
AC_ARG_ENABLE(transparent,
AS_HELP_STRING(--disable-transparent, disable transparent proxy support),