summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-06-11 17:56:52 +0000
committerNick Mathewson <nickm@torproject.org>2008-06-11 17:56:52 +0000
commita886e86cbd634cdf1411bae5280eb7c5275d08da (patch)
tree31ab555f15dd59b3eeff7c1303b14acea42f3389 /configure.in
parentb2fcc417d4e515059018f282149f95df9bd6caab (diff)
downloadtor-a886e86cbd634cdf1411bae5280eb7c5275d08da.tar.gz
tor-a886e86cbd634cdf1411bae5280eb7c5275d08da.zip
r16171@tombo: nickm | 2008-06-11 13:47:41 -0400
Lower number of syscalls used to write data to ordinary sockets through use of writev. Disabled till I have time to test it. svn:r15133
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d33da17e6e..cd68f4e440 100644
--- a/configure.in
+++ b/configure.in
@@ -196,7 +196,7 @@ dnl -------------------------------------------------------------------
dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.
-AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit strlcat strlcpy strtoull ftello getaddrinfo localtime_r gmtime_r memmem strtok_r inet_pton inet_ntop)
+AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit strlcat strlcpy strtoull ftello getaddrinfo localtime_r gmtime_r memmem strtok_r inet_pton inet_ntop writev readv)
using_custom_malloc=no
if test x$enable_openbsd_malloc = xyes ; then
@@ -311,7 +311,7 @@ AC_SYS_LARGEFILE
AC_CHECK_HEADERS(unistd.h string.h signal.h ctype.h sys/stat.h sys/types.h fcntl.h sys/fcntl.h sys/time.h errno.h assert.h time.h, , AC_MSG_WARN(Some headers were not found, compilation may fail. If compilation succeeds, please send your orconfig.h to the developers so we can fix this warning.))
-AC_CHECK_HEADERS(netdb.h sys/ioctl.h sys/socket.h arpa/inet.h netinet/in.h pwd.h grp.h sys/un.h)
+AC_CHECK_HEADERS(netdb.h sys/ioctl.h sys/socket.h arpa/inet.h netinet/in.h pwd.h grp.h sys/un.h sys/uio.h)
dnl These headers are not essential