summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-03-13 18:11:33 +0000
committerNick Mathewson <nickm@torproject.org>2008-03-13 18:11:33 +0000
commit0c6fc51909e53bb89558858438a0267fcc44fea1 (patch)
tree40cf9625d20fd08ac5d752aeb11472afe1404994 /configure.in
parent56580ae84e69bc4d1ce36012aa1003eb5303d6f9 (diff)
downloadtor-0c6fc51909e53bb89558858438a0267fcc44fea1.tar.gz
tor-0c6fc51909e53bb89558858438a0267fcc44fea1.zip
r18793@catbus: nickm | 2008-03-13 14:09:19 -0400
Add a malloc_good_size() implementation to OpenBSD_malloc_Linux.c. Also, make configure.in not use support functions for the platform malloc when we are not using the platform mallocs. svn:r14010
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c8543e399a..d2a568093e 100644
--- a/configure.in
+++ b/configure.in
@@ -183,7 +183,19 @@ dnl -------------------------------------------------------------------
dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.
-AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit strlcat strlcpy strtoull ftello getaddrinfo localtime_r gmtime_r memmem strtok_r inet_pton inet_ntop mallinfo malloc_good_size malloc_usable_size)
+AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit strlcat strlcpy strtoull ftello getaddrinfo localtime_r gmtime_r memmem strtok_r inet_pton inet_ntop)
+
+using_custom_malloc=no
+if test x$enable_openbsd_malloc = xyes ; then
+ AC_DEFINE(HAVE_MALLOC_GOOD_SIZE, 1, [Defined if we have the malloc_good_size function])
+ using_custom_malloc=yes
+fi
+if test x$tcmalloc = xyes ; then
+ using_custom_malloc=yes
+fi
+if test $using_custom_malloc = no ; then
+ AC_CHECK_FUNCS(mallinfo malloc_good_size malloc_usable_size)
+fi
if test "$enable_threads" = "yes"; then
AC_CHECK_HEADERS(pthread.h)