summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-01-15 23:07:11 +0000
committerNick Mathewson <nickm@torproject.org>2009-01-15 23:07:11 +0000
commit87124f54d0bb8489d4067f71a5bf350d9bdffac6 (patch)
tree4563f97e6354af5d743cd4bf3a5ac3dbcbec73c4 /configure.in
parentba7d786ab2a85724057fc691dc0994dffd7f0e82 (diff)
downloadtor-87124f54d0bb8489d4067f71a5bf350d9bdffac6.tar.gz
tor-87124f54d0bb8489d4067f71a5bf350d9bdffac6.zip
This patch changes the default location where config and data files
are stored when the --enable-local-appdata option is configured. This changes the Windows path from %APPDATA% to a host local %USERPROFILE%\Local Settings\Application Data\ path (aka, LOCAL_APPDATA). Patch from coderman. svn:r18122
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8cd4428853..42b6dcd923 100644
--- a/configure.in
+++ b/configure.in
@@ -96,6 +96,13 @@ fi
AC_ARG_ENABLE(gcc-warnings,
AS_HELP_STRING(--enable-gcc-warnings, enable verbose warnings))
+AC_ARG_ENABLE(local-appdata,
+ AS_HELP_STRING(--enable-local-appdata, default to host local application data paths on Windows))
+if test "$enable_local_appdata" = "yes"; then
+ AC_DEFINE(ENABLE_LOCAL_APPDATA, 1,
+ [Defined if we default to host local appdata paths on Windows])
+fi
+
AC_PROG_CC
AC_PROG_CPP
AC_PROG_MAKE_SET