summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-08-22 16:55:28 +0000
committerNick Mathewson <nickm@torproject.org>2008-08-22 16:55:28 +0000
commit80168d80d49bc2084e2d5ab0aa15e2afc40851b8 (patch)
treed72c41de636336a6c061dd701a26db5aac3aa9c0 /configure.in
parent865c19f29b9c8b2b4402475a9cf5a7d227f1d7e2 (diff)
downloadtor-80168d80d49bc2084e2d5ab0aa15e2afc40851b8.tar.gz
tor-80168d80d49bc2084e2d5ab0aa15e2afc40851b8.zip
r17853@tombo: nickm | 2008-08-22 12:55:00 -0400
Oops. We had been telling people to use --with-ssl-dir, which had not worked since 0.2.0.1-alpha: --with-openssl-dir was the one that worked. Make them both work, document --with-openssl-dir, and mark --with-ssl-dir as obsolete. Found by "Dave". svn:r16625
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4872cb7a22..7a1a56b8cc 100644
--- a/configure.in
+++ b/configure.in
@@ -283,10 +283,19 @@ tor_openssl_pkg_debian="libssl"
tor_openssl_devpkg_redhat="openssl-devel"
tor_openssl_devpkg_debian="libssl-dev"
+ALT_openssl_WITHVAL=""
+AC_ARG_WITH(ssl-dir,
+ [ --with-ssl-dir=PATH Obsolete alias for --with-openssl-dir ],
+ [
+ if test "x$withval" != xno && test "x$withval" != "x" ; then
+ ALT_openssl_WITHVAL="$withval"
+ fi
+ ])
+
TOR_SEARCH_LIBRARY(openssl, $tryssldir, [-lssl -lcrypto $TOR_LIB_GDI],
[#include <openssl/rand.h>],
[void RAND_add(const void *buf, int num, double entropy);],
- [RAND_add((void*)0,0,0); exit(0);], [--with-ssl-dir],
+ [RAND_add((void*)0,0,0); exit(0);], [],
[/usr/local/openssl /usr/lib/openssl /usr/local/ssl /usr/lib/ssl /usr/local /usr/athena /opt/openssl])
dnl XXXX check for OPENSSL_VERSION_NUMBER == SSLeay()