summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-03-13 06:40:37 +0000
committerNick Mathewson <nickm@torproject.org>2006-03-13 06:40:37 +0000
commitf8d4758a2669c615e7d20e09d5193a164088ac22 (patch)
tree73af9609512ebee19b47a5bb69335f9a2bc0495b /configure.in
parent331438b8abfff41ee5699be35af3b8856e7dffc4 (diff)
downloadtor-f8d4758a2669c615e7d20e09d5193a164088ac22.tar.gz
tor-f8d4758a2669c615e7d20e09d5193a164088ac22.zip
fix a flipped boolean. I had mistakenly assumed my OSX latptop was my friend
svn:r6152
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index dcc96949d0..4555f8ac43 100644
--- a/configure.in
+++ b/configure.in
@@ -292,7 +292,10 @@ int main(void)
AC_TRY_RUN([
#include <openssl/opensslv.h>
#include <openssl/crypto.h>
-int main(void) { return OPENSSL_VERSION_NUMBER == SSLeay(); }],
+#include <stdio.h>
+int main(void) {
+return (OPENSSL_VERSION_NUMBER == SSLeay()) == 0;
+}],
right_version=yes, right_version=no)
if test "$right_version" = yes; then
if test -z "$ssl_extra" ; then
@@ -314,7 +317,7 @@ int main(void) { return OPENSSL_VERSION_NUMBER == SSLeay(); }],
else
ac_cv_openssl_linker_option=$linked_with
fi
- AC_MSG_WARN([I managed to make OpenSSL link and run, but I couldn't make it run with the same version as the headers made us expect.])
+ AC_MSG_WARN([I managed to make OpenSSL link and run, but I couldn't make it link against with the same version I found header files for..])
fi
fi
LDFLAGS="$saved_LDFLAGS"