summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-11-02 19:25:52 +0000
committerNick Mathewson <nickm@torproject.org>2004-11-02 19:25:52 +0000
commit67f14032b18b7b46a56bd32ccb88923588603164 (patch)
treee226b607d34b77df664416b3ee2d123ecf4e88d1 /configure.in
parent509c0bdc22c5c36b8f6048e9beef852875de85d2 (diff)
downloadtor-67f14032b18b7b46a56bd32ccb88923588603164.tar.gz
tor-67f14032b18b7b46a56bd32ccb88923588603164.zip
Handle strlcat/strlcpy correctly on platforms that have them.
svn:r2647
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 50d952dde3..2b63da3d99 100644
--- a/configure.in
+++ b/configure.in
@@ -143,8 +143,7 @@ dnl These headers are not essential
AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h)
-AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit)
-AC_REPLACE_FUNCS(strlcat strlcpy)
+AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit strlcat strlcpy)
AC_CHECK_MEMBERS([struct timeval.tv_sec])
@@ -233,10 +232,10 @@ AC_SUBST(LOCALSTATEDIR)
# Set CFLAGS _after_ all the above checks, since our warnings are stricter
# than autoconf's macros like.
-CFLAGS="$CFLAGS -Wall -W -Wno-unused-parameter -Wfloat-equal -Wdeclaration-after-statement -Wundef -Wendif-labels -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -g -O2"
+CFLAGS="$CFLAGS -Wall -W -Wno-unused-parameter -Wfloat-equal -Wundef -Wendif-labels -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -g -O2"
# Add these in when you feel like fun.
-# -Wbad-function-cast -Werror
+# -Wbad-function-cast -Werror -Wdeclaration-after-statement
echo "confdir: $CONFDIR"