summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-02-03 21:31:04 +0000
committerNick Mathewson <nickm@torproject.org>2005-02-03 21:31:04 +0000
commita035032f09de213ae7f3137cfd3262067f4635a5 (patch)
treeafc0726b5284a3b1a2b80d1716a062eb45247081 /configure.in
parent4174bf9cbdaaab1b86dc7c051ebf11f53412272f (diff)
downloadtor-a035032f09de213ae7f3137cfd3262067f4635a5.tar.gz
tor-a035032f09de213ae7f3137cfd3262067f4635a5.zip
Use getaddrinfo and gethostbyname_r where available. Note that these are not necessarily threadsafe: this needs more thinking. Perhaps we should back down on this multithreading idea.
svn:r3522
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e8e80fe5ee..57489cae06 100644
--- a/configure.in
+++ b/configure.in
@@ -149,7 +149,7 @@ dnl These headers are not essential
AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h pthread.h)
-AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit strlcat strlcpy strtoull getpwnam ftello pthread_create)
+AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit strlcat strlcpy strtoull getpwnam ftello pthread_create gethostbyname_r getaddrinfo)
AC_FUNC_FSEEKO
AC_CHECK_MEMBERS([struct timeval.tv_sec])