summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-11-12 05:05:41 +0000
committerNick Mathewson <nickm@torproject.org>2004-11-12 05:05:41 +0000
commit5d92fbe30e30844a02c155f0874df6b086e4dc7d (patch)
treeb87313f84a9d7f02741004016d81c64b4bb29211 /configure.in
parent0faab62cd96a671f9018bd9cb8e23daf7eb3344f (diff)
downloadtor-5d92fbe30e30844a02c155f0874df6b086e4dc7d.tar.gz
tor-5d92fbe30e30844a02c155f0874df6b086e4dc7d.zip
Use autoconf to enable largefile support where necessary. Use ftello where available, since ftell can fail at 2GB.
svn:r2806
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 935a1a8fc9..c17eddc1ca 100644
--- a/configure.in
+++ b/configure.in
@@ -135,6 +135,8 @@ if (test ! -z "$ac_cv_openssldir" && test "x$ac_cv_openssldir" != "x(system)") ;
fi
LIBS="$saved_LIBS"
+AC_SYS_LARGEFILE
+
dnl The warning message here is no longer strictly accurate.
AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h poll.h sys/stat.h sys/poll.h sys/types.h fcntl.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h time.h pwd.h grp.h zlib.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
@@ -143,7 +145,7 @@ dnl These headers are not essential
AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h)
-AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit strlcat strlcpy strtoull getpwnam)
+AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit strlcat strlcpy strtoull getpwnam fseeko ftello)
AC_CHECK_MEMBERS([struct timeval.tv_sec])