summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-05-05 20:26:35 +0000
committerNick Mathewson <nickm@torproject.org>2004-05-05 20:26:35 +0000
commit8aebd83a0eb3e6cb312ccbf8e0cbd9b3b48294be (patch)
tree746b74818dc86fc4f393ad586e16b25bc83073c7 /configure.in
parente6ac85a8cc75ace50d5b64d324b50aaa112aff03 (diff)
downloadtor-8aebd83a0eb3e6cb312ccbf8e0cbd9b3b48294be.tar.gz
tor-8aebd83a0eb3e6cb312ccbf8e0cbd9b3b48294be.zip
Add intptr_t and uintptr_t to torint.h
svn:r1794
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 248c00dfcc..7981df8b17 100644
--- a/configure.in
+++ b/configure.in
@@ -153,8 +153,10 @@ AC_CHECK_SIZEOF(uint8_t)
AC_CHECK_SIZEOF(uint16_t)
AC_CHECK_SIZEOF(uint32_t)
AC_CHECK_SIZEOF(uint64_t)
+AC_CHECK_SIZEOF(intptr_t)
+AC_CHECK_SIZEOF(uintptr_t)
-dnl AC_CHECK_TYPES([int8_t, int16_t, int32_t, int64_t, uint8_t, uint16_t, uint32_t, uint64_t])
+dnl AC_CHECK_TYPES([int8_t, int16_t, int32_t, int64_t, uint8_t, uint16_t, uint32_t, uint64_t, intptr_t, uintptr_t])
AC_CHECK_SIZEOF(char)
AC_CHECK_SIZEOF(short)
@@ -162,6 +164,7 @@ AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(__int64)
+AC_CHECK_SIZEOF(void *)
# Now, let's see about alignment requirements
AC_CACHE_CHECK([whether unaligned int access is allowed], tor_cv_unaligned_ok,