summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2003-08-11 20:40:21 +0000
committerNick Mathewson <nickm@torproject.org>2003-08-11 20:40:21 +0000
commit52675184552c7284d4b4eb9a55f098cc80319f85 (patch)
tree8157d4e25f7a1fd355426dcb48462ee2303393f1 /configure.in
parent681c7539ef9a7ec3b0b2e6c1da551397820f7589 (diff)
downloadtor-52675184552c7284d4b4eb9a55f098cc80319f85.tar.gz
tor-52675184552c7284d4b4eb9a55f098cc80319f85.zip
autoconf around missing stdint.h
svn:r376
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a1f573b014..f977d4e9a8 100644
--- a/configure.in
+++ b/configure.in
@@ -135,5 +135,15 @@ dnl The warning message here is no longer strictly accurate.
AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h poll.h sys/poll.h sys/types.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h stdint.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
+dnl In case we aren't given a working stdint.h, we'll need to grow our own.
+dnl Watch out.
+
+AC_CHECK_SIZEOF(char)
+AC_CHECK_SIZEOF(short)
+AC_CHECK_SIZEOF(int)
+AC_CHECK_SIZEOF(long)
+AC_CHECK_SIZEOF(long long)
+AC_CHECK_SIZEOF(__int64)
+
AC_OUTPUT(Makefile src/Makefile src/common/Makefile src/orkeygen/Makefile src/or/Makefile)