aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarsten Loesing <karsten.loesing@gmx.net>2009-07-05 19:53:25 +0200
committerKarsten Loesing <karsten.loesing@gmx.net>2009-07-05 19:53:25 +0200
commitb493a2ccb97e00f4fe3acb5c59c941c2babaeebb (patch)
treeeec79d7610ffc84657bfed515cfd948970377e39 /configure.in
parent4d6af73db88e409764f43fc6cdaa432d667becf3 (diff)
downloadtor-b493a2ccb97e00f4fe3acb5c59c941c2babaeebb.tar.gz
tor-b493a2ccb97e00f4fe3acb5c59c941c2babaeebb.zip
If configured, write cell statistics to disk periodically.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 844211588d..10b05aeffb 100644
--- a/configure.in
+++ b/configure.in
@@ -99,6 +99,13 @@ if test "$enable_geoip_stats" = "yes"; then
AC_DEFINE(ENABLE_GEOIP_STATS, 1, [Defined if we try to collect per-country statistics])
fi
+AC_ARG_ENABLE(buffer-stats,
+ AS_HELP_STRING(--enable-buffer-stats, enable code for relays to collect buffer statistics))
+
+if test "$enable_buffer_stats" = "yes"; then
+ AC_DEFINE(ENABLE_BUFFER_STATS, 1, [Defined if we try to collect buffer statistics])
+fi
+
AC_ARG_ENABLE(gcc-warnings,
AS_HELP_STRING(--enable-gcc-warnings, enable verbose warnings))