aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2011-09-13 19:51:37 -0400
committerNick Mathewson <nickm@torproject.org>2011-09-13 19:51:37 -0400
commit296649fd2b0aa1d0c328ca8b494d746a75cbb28b (patch)
treee485f3acbb1a2ba327b4f2cfc01adfbe62afcbbd /configure.in
parentbefaa435bd9ba60a10e1d796ad66f405a5889086 (diff)
downloadtor-296649fd2b0aa1d0c328ca8b494d746a75cbb28b.tar.gz
tor-296649fd2b0aa1d0c328ca8b494d746a75cbb28b.zip
Provide missing description for our FLEXIBLE_ARRAY_MEMBER defines
Apparently autoheader throws a tantrum if you say 'AC_DEFINE([a], [b])'. Instead you must say 'AC_DEFINE([a], [b], [description of a])'. We were running into this in our replacement definitions for FLEXIBLE_ARRAY_MEMBER, which were only getting built on autoconf versions before 2.61 -- and this made us stop working with those autoconf versinos. Fixes bug 2430; bugfix on 0.2.3.1-alpha.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a449136f93..c6ee589987 100644
--- a/configure.in
+++ b/configure.in
@@ -189,9 +189,9 @@ AC_C_FLEXIBLE_ARRAY_MEMBER
[tor_cv_c_flexarray=yes],
[tor_cv_c_flexarray=no])])
if test $tor_cv_flexarray = yes ; then
- AC_DEFINE([FLEXIBLE_ARRAY_MEMBER], [])
+ AC_DEFINE([FLEXIBLE_ARRAY_MEMBER], [], [Define to nothing if C supports flexible array members, and to 1 if it does not.])
else
- AC_DEFINE([FLEXIBLE_ARRAY_MEMBER], [1])
+ AC_DEFINE([FLEXIBLE_ARRAY_MEMBER], [1], [Define to nothing if C supports flexible array members, and to 1 if it does not.])
fi
])