aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-08-10 09:01:37 +0000
committerNick Mathewson <nickm@torproject.org>2006-08-10 09:01:37 +0000
commit5cff4164a08af2a869e5e85aa6d359b865eee9aa (patch)
treee529cd925b0c3634b512bf638e9edb31dbde22f2 /configure.in
parent8cbd03fdaf3c138a2ca41b41c995643146fdac94 (diff)
downloadtor-5cff4164a08af2a869e5e85aa6d359b865eee9aa.tar.gz
tor-5cff4164a08af2a869e5e85aa6d359b865eee9aa.zip
r7299@Kushana: nickm | 2006-08-10 01:08:58 -0700
Patch from Tup to add support for transparent AP connections: this basically bundles the functionality of trans-proxy-tor into the tor mainline. Now hosts with compliant pf/netfilter implementations can redirect TCP connections straight to Tor without diverting through SOCKS. svn:r7007
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8f0f543615..f8adb490b1 100644
--- a/configure.in
+++ b/configure.in
@@ -56,6 +56,26 @@ if test x$eventdns = xtrue; then
AC_DEFINE([USE_EVENTDNS], 1, "Define to 1 if we'll be using eventdns.c")
fi
+AC_ARG_ENABLE(transparent,
+ AC_HELP_STRING(--disable-transparent, disable transparent proxy support),
+ [case "${enableval}" in
+ yes) transparent=true ;;
+ no) transparent=false ;;
+ *) AC_MSG_ERROR(bad value for --enable-transparent) ;;
+ esac], [transparent=true])
+if test x$transparent = xtrue; then
+ AC_DEFINE(USE_TRANSPARENT, 1, "Define to enable transparent proxy support")
+ case $host in
+ *-*-linux* )
+ AC_DEFINE(TRANS_NETFILTER, 1, "Define for transparent netfilter") ;;
+ *-*-openbsd*)
+ AC_DEFINE(TRANS_PF, 1, "Define for transparent pf")
+ AC_DEFINE(OPENBSD, 1, "Define to handle pf on OpenBSD properly") ;;
+ *-*-*bsd* )
+ AC_DEFINE(TRANS_PF, 1, "Define for transparent pf") ;;
+ esac
+fi
+
case $host in
*-*-solaris* )
AC_DEFINE(_REENTRANT, 1, [Define on some platforms to activate x_r() functions in time.h])