aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2006-02-01 02:15:44 +0000
committerPeter Palfrader <peter@palfrader.org>2006-02-01 02:15:44 +0000
commitdbf2e104609ba4f4f48766c5f59b87ee67f8ee8c (patch)
tree5b6917e5f91e69aabdcf1cf36e1b6a7e3ccb865f /configure.in
parent415544bb753d915f04b84c4c65eddc6ff42e6fd4 (diff)
downloadtor-dbf2e104609ba4f4f48766c5f59b87ee67f8ee8c.tar.gz
tor-dbf2e104609ba4f4f48766c5f59b87ee67f8ee8c.zip
Apply Matt Ghali's --with-syslog-facility patch
svn:r5883
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 58eef6c8d9..e85425c060 100644
--- a/configure.in
+++ b/configure.in
@@ -429,6 +429,13 @@ if [[ $dmalloc -eq 1 ]]; then
AC_DEFINE(DMALLOC_FUNC_CHECK, 1, [Enable dmalloc's malloc function check])
fi
+# Allow user to specify an alternate syslog facility
+AC_ARG_WITH(syslog-facility,
+[ --with-syslog-facility=LOG syslog facility to use (default=LOG_DAEMON)],
+syslog_facility="$withval", syslog_facility="LOG_DAEMON")
+AC_DEFINE_UNQUOTED(LOGFACILITY,$syslog_facility,[name of the syslog facility])
+AC_SUBST(LOGFACILITY)
+
# Check for gethostbyname_r in all its glorious incompatible versions.
# (This logic is based on that in Python's configure.in)
AH_TEMPLATE(HAVE_GETHOSTBYNAME_R,