aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarsten Loesing <karsten.loesing@gmx.net>2009-06-24 19:51:45 +0200
committerNick Mathewson <nickm@torproject.org>2009-07-02 12:37:05 -0400
commit4d6af73db88e409764f43fc6cdaa432d667becf3 (patch)
treede8f80573fc939975f8e6e8bb0d6becf39621045 /configure.in
parent078c34e28e02bcb3a9fd28f3fee3c5e956ec8e1f (diff)
downloadtor-4d6af73db88e409764f43fc6cdaa432d667becf3.tar.gz
tor-4d6af73db88e409764f43fc6cdaa432d667becf3.zip
If configured, write per-port exit statistics to disk periodically.
[Original patch series from Karsten, revised and squashed by Nick]
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f1ac83687c..844211588d 100644
--- a/configure.in
+++ b/configure.in
@@ -85,6 +85,13 @@ case $host in
;;
esac
+AC_ARG_ENABLE(exit-stats,
+ AS_HELP_STRING(--enable-exit-stats, enable code for exits to collect per-port statistics))
+
+if test "$enable_exit_stats" = "yes"; then
+ AC_DEFINE(ENABLE_EXIT_STATS, 1, [Defined if we try to collect per-port statistics on exits])
+fi
+
AC_ARG_ENABLE(geoip-stats,
AS_HELP_STRING(--enable-geoip-stats, enable code for directories to collect per-country statistics))