aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-05-23 08:23:03 +0000
committerNick Mathewson <nickm@torproject.org>2006-05-23 08:23:03 +0000
commit89a8411acec388612c71a0268752cbc0d5f958d4 (patch)
tree7ba1d7f7abdf839299a203eefd00a1a312cd7866 /configure.in
parent13c4590dd19351f55e8eb6830e44d64897b72c73 (diff)
downloadtor-89a8411acec388612c71a0268752cbc0d5f958d4.tar.gz
tor-89a8411acec388612c71a0268752cbc0d5f958d4.zip
Throw out this UNALIGNED_INT_ACCESS_OK nonsense. Even where it works, it is often way way slower than doing the right thing. Backport candidate.
svn:r6473
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index 813510200c..6027a61b1f 100644
--- a/configure.in
+++ b/configure.in
@@ -398,35 +398,6 @@ AC_CHECK_SIZEOF(socklen_t, , [AC_INCLUDES_DEFAULT()
AC_CHECK_SIZEOF(cell_t)
-# Now, let's see about alignment requirements. On some platforms, we override
-# the default.
-case $host in
- ia64-*-* | arm-*-* | sparc-*-* | sparc64-*-* )
- tor_cv_unaligned_ok=no
- ;;
- # On the following architectures unaligned access works, but is not done in
- # hardware. This means that when you try to do unaligned access the kernel
- # gets to sort out an exception and then work around to somehow make your
- # reqest work, which is quite expensive. Therefore it's probably better to
- # not even do it.
- alpha-*-* | mips-*-* | mipsel-*-* )
- tor_cv_unaligned_ok=no
- ;;
- *)
-AC_CACHE_CHECK([whether unaligned int access is allowed], tor_cv_unaligned_ok,
-[AC_RUN_IFELSE([AC_LANG_SOURCE(
-[[int main () { char s[] = "A\x00\x00\x00\x00\x00\x00\x00";
-return *(int*)(&s[1]); }]])],
- [tor_cv_unaligned_ok=yes],
- [tor_cv_unaligned_ok=no],
- [tor_cv_unaligned_ok=cross])])
-esac
-
-if test $tor_cv_unaligned_ok = yes; then
- AC_DEFINE([UNALIGNED_INT_ACCESS_OK], 1,
- [Define to 1 iff unaligned int access is allowed])
-fi
-
# Now make sure that NULL can be represented as zero bytes.
AC_CACHE_CHECK([whether memset(0) sets pointers to NULL], tor_cv_null_is_zero,
[AC_RUN_IFELSE([AC_LANG_SOURCE(