aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2010-02-02 16:12:45 -0500
committerNick Mathewson <nickm@torproject.org>2010-02-02 16:12:45 -0500
commitf6ff14a82ead43e3f5c2a6b2f2ace45ca2f45081 (patch)
tree99b0b2d3db14bab43db019c9a53e99d8573b8bbe /configure.in
parentabd447f87667c21f8a5c2134d456cb5c1555d7c7 (diff)
downloadtor-f6ff14a82ead43e3f5c2a6b2f2ace45ca2f45081.tar.gz
tor-f6ff14a82ead43e3f5c2a6b2f2ace45ca2f45081.zip
Link libssl and libcrypto in the right order.
For most linking setups, this doesn't matter. But for some setups, when statically linking openssl, it does matter, since you need to link things with dependencies before you link things they depend on. Fix for bug 1237.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 92dc45fd68..86fa2eb1c2 100644
--- a/configure.in
+++ b/configure.in
@@ -326,12 +326,11 @@ if test "$enable_static_openssl" = "yes"; then
if test "$tor_cv_library_openssl_dir" = "(system)"; then
AC_MSG_ERROR("You must specify an explicit --with-openssl-dir=x option when using --enable-static-openssl")
else
- TOR_OPENSSL_LIBS="$TOR_LIBDIR_openssl/libcrypto.a $TOR_LIBDIR_openssl/libssl.a"
+ TOR_OPENSSL_LIBS="$TOR_LIBDIR_openssl/libssl.a $TOR_LIBDIR_openssl/libcrypto.a"
fi
else
- TOR_OPENSSL_LIBS="-lcrypto -lssl"
+ TOR_OPENSSL_LIBS="-lssl -lcrypto"
fi
-echo "TOR_OPENSSL_LIBS=$TOR_OPENSSL_LIBS"
AC_SUBST(TOR_OPENSSL_LIBS)
dnl ------------------------------------------------------