aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-09-28 00:53:02 +0000
committerNick Mathewson <nickm@torproject.org>2006-09-28 00:53:02 +0000
commit95132f836a280890d0d69c505f65b809dd4a5179 (patch)
tree58b1486a9d0ff8edea41f18a4cf35a8050a38800 /configure.in
parentba7868c7b312dc16236d3c5ac73028a4e732538c (diff)
downloadtor-95132f836a280890d0d69c505f65b809dd4a5179.tar.gz
tor-95132f836a280890d0d69c505f65b809dd4a5179.zip
r8750@totoro: nickm | 2006-09-27 20:52:01 -0400
Fix some warnings on mingw; hopefully this should let us build on mingw without warnings. svn:r8509
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f177ad7386..45a1ffc54f 100644
--- a/configure.in
+++ b/configure.in
@@ -403,7 +403,9 @@ AC_SYS_LARGEFILE
dnl The warning message here is no longer strictly accurate.
-AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h sys/stat.h sys/types.h fcntl.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h time.h pwd.h grp.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
+AC_CHECK_HEADERS(unistd.h string.h signal.h ctype.h sys/stat.h sys/types.h fcntl.h sys/fcntl.h sys/time.h errno.h assert.h time.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
+
+AC_CHECK_HEADERS(netdb.h sys/ioctl.h sys/socket.h arpa/inet.h netinet/in.h pwd.h grp.h)
AC_CHECK_HEADERS(event.h, , AC_MSG_ERROR(Libevent header (event.h) not found. Tor requires libevent to build.),
[#ifdef HAVE_SYS_TYPES_H
@@ -501,6 +503,7 @@ AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(__int64)
AC_CHECK_SIZEOF(void *)
AC_CHECK_SIZEOF(time_t)
+AC_CHECK_SIZEOF(size_t)
AC_CHECK_TYPES([uint, u_char])