summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-11-02 03:02:17 +0000
committerNick Mathewson <nickm@torproject.org>2004-11-02 03:02:17 +0000
commitad4dc7448257c229860206b078e02778bcb1b408 (patch)
tree823243e7bc13876a466176db862028402dd4526b /configure.in
parent85c79ffbc7b965355c3b51cc81000d517089e74e (diff)
downloadtor-ad4dc7448257c229860206b078e02778bcb1b408.tar.gz
tor-ad4dc7448257c229860206b078e02778bcb1b408.zip
Use a stricter set of warnings; make them all pass.
svn:r2645
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6fc7ae1510..50d952dde3 100644
--- a/configure.in
+++ b/configure.in
@@ -5,8 +5,6 @@ AM_CONFIG_HEADER(orconfig.h)
AC_CANONICAL_HOST
-CFLAGS="$CFLAGS -Wall -g -O2"
-
if test -f /etc/redhat-release; then
CFLAGS="$CFLAGS -I/usr/kerberos/include"
fi
@@ -233,6 +231,13 @@ AC_SUBST(BINDIR)
LOCALSTATEDIR=`eval echo $localstatedir`
AC_SUBST(LOCALSTATEDIR)
+# Set CFLAGS _after_ all the above checks, since our warnings are stricter
+# than autoconf's macros like.
+CFLAGS="$CFLAGS -Wall -W -Wno-unused-parameter -Wfloat-equal -Wdeclaration-after-statement -Wundef -Wendif-labels -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -g -O2"
+
+# Add these in when you feel like fun.
+# -Wbad-function-cast -Werror
+
echo "confdir: $CONFDIR"
AC_OUTPUT(Makefile contrib/tor.sh contrib/torify contrib/Makefile src/config/torrc.sample doc/tor.1 src/Makefile doc/Makefile doc/design-paper/Makefile src/config/Makefile src/common/Makefile src/or/Makefile src/win32/Makefile src/tools/Makefile)