summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-07-03 10:25:31 -0400
committerNick Mathewson <nickm@torproject.org>2018-07-03 10:25:31 -0400
commite2a94dc48147c9bad1f09f8b14df3bec0e3f5e94 (patch)
treeb7badc1868939a516ae1c455699bab513bd03087 /configure.ac
parenta01b4d7f87f2217f55f5c5113fe19a2d3081a44c (diff)
downloadtor-e2a94dc48147c9bad1f09f8b14df3bec0e3f5e94.tar.gz
tor-e2a94dc48147c9bad1f09f8b14df3bec0e3f5e94.zip
Require stdint.h and inttypes.h
We've been silently requiring stdint.h for a while now, and nobody has complained. Closes ticket 26626.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 98635bcbd8..557a81f41f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1393,7 +1393,6 @@ AC_CHECK_HEADERS([errno.h \
netinet/in6.h \
pwd.h \
readpassphrase.h \
- stdint.h \
stdatomic.h \
sys/eventfd.h \
sys/file.h \
@@ -1517,22 +1516,6 @@ AC_CHECK_MEMBERS([struct timeval.tv_sec], , ,
#include <sys/time.h>
#endif])
-dnl In case we aren't given a working stdint.h, we'll need to grow our own.
-dnl Watch out.
-
-AC_CHECK_SIZEOF(int8_t)
-AC_CHECK_SIZEOF(int16_t)
-AC_CHECK_SIZEOF(int32_t)
-AC_CHECK_SIZEOF(int64_t)
-AC_CHECK_SIZEOF(uint8_t)
-AC_CHECK_SIZEOF(uint16_t)
-AC_CHECK_SIZEOF(uint32_t)
-AC_CHECK_SIZEOF(uint64_t)
-AC_CHECK_SIZEOF(intptr_t)
-AC_CHECK_SIZEOF(uintptr_t)
-
-dnl AC_CHECK_TYPES([int8_t, int16_t, int32_t, int64_t, uint8_t, uint16_t, uint32_t, uint64_t, intptr_t, uintptr_t])
-
AC_CHECK_SIZEOF(char)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)