summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-03-23 12:38:27 -0400
committerNick Mathewson <nickm@torproject.org>2018-03-23 12:38:27 -0400
commit398bef2592010e71692dd9c3b5b90d3751c48bb2 (patch)
treef01002ff6c2ea0e9a689a9b2adfd68213862d9c1 /configure.ac
parentbb9012c818124a6fed3321bdbd6bc46c63e89341 (diff)
downloadtor-398bef2592010e71692dd9c3b5b90d3751c48bb2.tar.gz
tor-398bef2592010e71692dd9c3b5b90d3751c48bb2.zip
Define SRCDIR more correctly in configure.ac
Without this fix, we were just getting SRCDIR=`pwd`, which naturally was breaking out-of-tree builds. Bugfix on becae4c943969a4f4f14423cc897d39f41af7773; bug not in any released Tor.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6fadc21df4..d7cc05c098 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1879,7 +1879,7 @@ AH_TEMPLATE([BUILDDIR],[tor's build directory])
AC_DEFINE_UNQUOTED(BUILDDIR,"$BUILDDIR")
if test "x$SRCDIR" = "x"; then
- SRCDIR=`pwd`
+ SRCDIR=$(cd "$srcdir"; pwd)
fi
AH_TEMPLATE([SRCDIR],[tor's sourcedir directory])
AC_DEFINE_UNQUOTED(SRCDIR,"$SRCDIR")