summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-05-19 16:01:25 -0400
committerNick Mathewson <nickm@torproject.org>2016-05-19 16:01:25 -0400
commitae7e2b9a7cd95ad04d3d416fd58cc20f8c4f06bd (patch)
tree172cf7b368d9ee62631ef6272f2845facf821532 /configure.ac
parent6d6c8287d5e060117bfa066f87d4e2fc08ab708d (diff)
downloadtor-ae7e2b9a7cd95ad04d3d416fd58cc20f8c4f06bd.tar.gz
tor-ae7e2b9a7cd95ad04d3d416fd58cc20f8c4f06bd.zip
add missing atoi for cosmetic reasons
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8465b43262..f8cad48b17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,7 +812,7 @@ if test "$have_clang" = "yes"; then
int main(int argc, char **argv)
{
int64_t x = ((int64_t)atoi(argv[1])) * (int64_t)atoi(argv[2])
- * (int64_t)argv[3];
+ * (int64_t)atoi(argv[3]);
return x == 9;
} ]])],
[ftrapv_can_link=yes; AC_MSG_RESULT([yes])],
@@ -831,7 +831,7 @@ if test "$have_clang" = "yes"; then
int main(int argc, char **argv)
{
int64_t x = ((int64_t)atoi(argv[1])) * (int64_t)atoi(argv[2])
- * (int64_t)argv[3];
+ * (int64_t)atoi(argv[3]);
return x == 9;
} ]])],
[mulodi_fixes_ftrapv=yes; AC_MSG_RESULT([yes])],