summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-12-16 12:16:52 -0500
committerNick Mathewson <nickm@torproject.org>2016-12-16 12:16:52 -0500
commit2a00110e5bd3592ff69e659681b9294285a98dd0 (patch)
treed262b5abd118dcebd6a11eb6fc0f3d3aa1f2094c /configure.ac
parent79a24750ba8b3b1efc87c5b43d91229b6478ef82 (diff)
downloadtor-2a00110e5bd3592ff69e659681b9294285a98dd0.tar.gz
tor-2a00110e5bd3592ff69e659681b9294285a98dd0.zip
Revert "Stop checking whether environ is declared."
This reverts commit 954eeda619a59dae76144ad69967f0ed7341b564. Apparently, OpenBSD is what expects you to declare environ yourself. So 19142 is a wontfix.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 552465c77c..fea884b2f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1535,6 +1535,17 @@ int main(int c, char **v) { puts(__FUNCTION__); }])],
tor_cv_have_FUNCTION_macro=yes,
tor_cv_have_FUNCTION_macro=no))
+AC_CACHE_CHECK([whether we have extern char **environ already declared],
+ tor_cv_have_environ_declared,
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+#ifdef HAVE_UNISTD_H
+#include <unistd.h>
+#endif
+#include <stdlib.h>
+int main(int c, char **v) { char **t = environ; }])],
+ tor_cv_have_environ_declared=yes,
+ tor_cv_have_environ_declared=no))
+
if test "$tor_cv_have_func_macro" = "yes"; then
AC_DEFINE(HAVE_MACRO__func__, 1, [Defined if the compiler supports __func__])
fi
@@ -1548,6 +1559,11 @@ if test "$tor_cv_have_FUNCTION_macro" = "yes"; then
[Defined if the compiler supports __FUNCTION__])
fi
+if test "$tor_cv_have_environ_declared" = "yes"; then
+ AC_DEFINE(HAVE_EXTERN_ENVIRON_DECLARED, 1,
+ [Defined if we have extern char **environ already declared])
+fi
+
# $prefix stores the value of the --prefix command line option, or
# NONE if the option wasn't set. In the case that it wasn't set, make
# it be the default, so that we can use it to expand directories now.