summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2021-11-05 13:23:05 -0400
committerNick Mathewson <nickm@torproject.org>2021-11-05 13:23:05 -0400
commit8beb560bfd19106ab75e13f6bf6230fde93e5fac (patch)
tree9c3fce5f81349c41d170f7a52180ef36a2aacd9a /configure.ac
parentcfd1482f78b4542703b078587c5d52309ce8b999 (diff)
downloadtor-8beb560bfd19106ab75e13f6bf6230fde93e5fac.tar.gz
tor-8beb560bfd19106ab75e13f6bf6230fde93e5fac.zip
Reverse the direction of the test for openssl 3.0.0
Previously the logic was reversed, and always gave the wrong answer. This has no other effect than to change whether we suppress deprecated API warnings. Fixes #40429; bugfix on 0.3.5.13.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 930862442c..249a250a2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -945,7 +945,7 @@ dnl warnings.
AC_MSG_CHECKING([for OpenSSL >= 3.0.0])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <openssl/opensslv.h>
-#if !defined(LIBRESSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER <= 0x30000000L
+#if !defined(LIBRESSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER >= 0x30000000L
#error "you_have_version_3"
#endif
]], [[]])],