summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2021-01-19 11:59:58 -0500
committerNick Mathewson <nickm@torproject.org>2021-01-19 11:59:58 -0500
commitf8cf2546ea6731d6fdca6a7cfc52d047bc47bb8b (patch)
treed797634b66a591fe0a217071895d41e65246e9b2 /configure.ac
parente5a0c739d4865b300e904d45c413d5c8f0da304c (diff)
parent8230d2ba3b9d571df4c7a425daa872d41a4f3180 (diff)
downloadtor-f8cf2546ea6731d6fdca6a7cfc52d047bc47bb8b.tar.gz
tor-f8cf2546ea6731d6fdca6a7cfc52d047bc47bb8b.zip
Merge remote-tracking branch 'tor-gitlab/mr/258' into maint-0.4.5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6d50dc9508..41c627021a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -357,6 +357,12 @@ dnl ---
dnl All our modules.
m4_define(MODULES, relay dirauth dircache)
+# Some modules are only disabled through another option. For those, we don't
+# want to print the help in the summary at the end of the configure. Any entry
+# in the following set will not print the "--disable-module-NAME" command in
+# the summary.
+m4_set_add_all([MODULES_WITH_NO_OPTIONS], [dircache])
+
dnl Relay module.
AC_ARG_ENABLE([module-relay],
AS_HELP_STRING([--disable-module-relay],
@@ -2821,7 +2827,9 @@ PPRINT_SUBTITLE([Modules])
m4_foreach_w([mname], MODULES,
[
AM_COND_IF(m4_join([], [BUILD_MODULE_], m4_toupper([]mname[])), value=1, value=0)
- PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value)
+ m4_set_contains([MODULES_WITH_NO_OPTIONS], mname,
+ PPRINT_PROP_BOOL([mname], $value),
+ PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value))
]
)