summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2021-02-17 12:36:23 -0500
committerNick Mathewson <nickm@torproject.org>2021-02-17 12:36:23 -0500
commitaebd0a4080559a5c24e580ddf50e5b5c8ff1cc29 (patch)
tree69e0dee3b9a314654eee38375f0588c9f1069fb0 /configure.ac
parent336c45f1a5b30b31cbb76a2622a6e80d755db2b5 (diff)
downloadtor-aebd0a4080559a5c24e580ddf50e5b5c8ff1cc29.tar.gz
tor-aebd0a4080559a5c24e580ddf50e5b5c8ff1cc29.zip
Make our configure.ac script use the portable `=` comparison
Back in 0.4.5.1-alpha we added an `==` comparison, which isn't portable. Fixes bug #40298; bugfix on 0.4.5.1-alpha.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a8d95e49eb..e8775a98f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1144,7 +1144,7 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([AC_LANG_PROGRAM([[
]])])], [openssl_ver_mismatch=no], [
# This is a kludge to figure out whether compilation failed, or whether
# running the program failed.
- if test "$ac_retval" == "1"; then
+ if test "$ac_retval" = "1"; then
openssl_ver_mismatch=inconclusive
else
openssl_ver_mismatch=yes