summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2021-01-19 12:00:06 -0500
committerNick Mathewson <nickm@torproject.org>2021-01-19 12:00:06 -0500
commit85c4087de9b80c2174e47359a5a97f5fac5c0c10 (patch)
tree40438c6a1cb388fff6b08a86f21a26ddef9a0bb8 /configure.ac
parentaa0c4fd86d504e65c1a776ad6551496d7eb5c4de (diff)
parentf8cf2546ea6731d6fdca6a7cfc52d047bc47bb8b (diff)
downloadtor-85c4087de9b80c2174e47359a5a97f5fac5c0c10.tar.gz
tor-85c4087de9b80c2174e47359a5a97f5fac5c0c10.zip
Merge branch 'maint-0.4.5'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 95284086be..0ec813658c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,6 +359,12 @@ dnl ---
dnl All our modules.
m4_define(MODULES, relay dirauth dircache)
+# Some modules are only disabled through another option. For those, we don't
+# want to print the help in the summary at the end of the configure. Any entry
+# in the following set will not print the "--disable-module-NAME" command in
+# the summary.
+m4_set_add_all([MODULES_WITH_NO_OPTIONS], [dircache])
+
dnl Relay module.
AC_ARG_ENABLE([module-relay],
AS_HELP_STRING([--disable-module-relay],
@@ -2834,7 +2840,9 @@ PPRINT_SUBTITLE([Modules])
m4_foreach_w([mname], MODULES,
[
AM_COND_IF(m4_join([], [BUILD_MODULE_], m4_toupper([]mname[])), value=1, value=0)
- PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value)
+ m4_set_contains([MODULES_WITH_NO_OPTIONS], mname,
+ PPRINT_PROP_BOOL([mname], $value),
+ PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value))
]
)