summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2020-09-23 10:53:09 -0400
committerDavid Goulet <dgoulet@torproject.org>2020-10-07 09:00:06 -0400
commit9ad525604e274b4bc5264db37b1049da3d39ddac (patch)
tree3d1530e9067c3e5b2dcf8a68c55cff7f13a1d5c3 /configure.ac
parent59c36b9b58010f658e022cf19e20e2c74103f258 (diff)
downloadtor-9ad525604e274b4bc5264db37b1049da3d39ddac.tar.gz
tor-9ad525604e274b4bc5264db37b1049da3d39ddac.zip
Use AC_LANG_SOURCE
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a14b6d6e21..9b65a869f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1094,7 +1094,7 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
dnl Let's see if we have a version mismatch between includes and libs.
AC_MSG_CHECKING([for significant mismatch between openssl headers and libraries])
ac_retval=foo
-AC_RUN_IFELSE(AC_LANG_PROGRAM([[
+AC_RUN_IFELSE([AC_LANG_SOURCE([AC_LANG_PROGRAM([[
#include <openssl/opensslv.h>
#include <openssl/crypto.h>
]], [[
@@ -1103,7 +1103,7 @@ AC_RUN_IFELSE(AC_LANG_PROGRAM([[
unsigned long linking = OpenSSL_version_num() & mask;
unsigned long running = OPENSSL_VERSION_NUMBER & mask;
return !(linking==running);
-]]), [openssl_ver_mismatch=no], [
+]])])], [openssl_ver_mismatch=no], [
# This is a kludge to figure out whether compilation failed, or whether
# running the program failed.
if test "$ac_retval" == "1"; then