summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2020-12-11 09:52:23 -0500
committerDavid Goulet <dgoulet@torproject.org>2020-12-11 09:52:23 -0500
commit15b0d30a553e2e3e7eba2539d6531025a0272d2c (patch)
treee16b96aea8a18999625b5078f7f2040c4cfc8032 /configure.ac
parente74f168bb4df0b06d4f224421570e160cfcdb7a9 (diff)
downloadtor-15b0d30a553e2e3e7eba2539d6531025a0272d2c.tar.gz
tor-15b0d30a553e2e3e7eba2539d6531025a0272d2c.zip
configure: Revert back the static libevent path
From c618c4f27986825df2026fb22b8ee222edd1afa1, we changed the static libevent.a path to be able to use the git repository or tarball directly but that broke the "make install" setup that Tor Browser is using with Android. In other words, the git repository and tarball put the "libevent.a" in ".libs/" where "make install" puts it in "lib/". Using the --with-libevent-dir=..., which is mandatory for static libevent, autoconf will take the path and use it for the includes (-I) and library (-L) for which if it finds a "include/" and a "lib/" in the root, it will use those. However, with the git repo or tarball, the "lib/" doesn't exists thus autoconf sets the library search path to be at the root and thus fails to find the libevent.a in ".libs/". This is a whole lot more work to make both cases work in our configure.ac thus I'm reverting the change here to the Tor Browser case works again and the work around for others is to either symlink the libevent.a at the root or use a temporary make install directory. One long term fix here would likely be to ask libevent to symblink the .a into the root along the .la files and likely do the same for .so. Or, use the "lib/" structure to contain the .a + .so files. Would be better than doing ninji-tsu in our configure.ac Fixes #40225 Signed-off-by: David Goulet <dgoulet@torproject.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 83f6ad1821..1c3fa7d15c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -954,7 +954,7 @@ if test "$enable_static_libevent" = "yes"; then
if test "$tor_cv_library_libevent_dir" = "(system)"; then
AC_MSG_ERROR("You must specify an explicit --with-libevent-dir=x option when using --enable-static-libevent")
else
- TOR_LIBEVENT_LIBS="$TOR_LIBDIR_libevent/.libs/libevent.a $STATIC_LIBEVENT_FLAGS"
+ TOR_LIBEVENT_LIBS="$TOR_LIBDIR_libevent/libevent.a $STATIC_LIBEVENT_FLAGS"
fi
else
if test "x$ac_cv_header_event2_event_h" = "xyes"; then