summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-11-05 08:37:22 -0500
committerNick Mathewson <nickm@torproject.org>2019-11-05 08:37:22 -0500
commit4c2c98900b7698469cea02a57c977dc636ec1f65 (patch)
tree9963e177719c6528b19440a547c0731e6174604b /configure.ac
parent6e023d55851f4287ffac5eef83721a43ee0a4319 (diff)
downloadtor-4c2c98900b7698469cea02a57c977dc636ec1f65.tar.gz
tor-4c2c98900b7698469cea02a57c977dc636ec1f65.zip
doxygen: Use @SRCDIR@ instead of @top_srcdir@.
Our @top_srcdir@ directory can contain "..", which confuses doxygen when it tries to make references to directories. Using @abs_top_srcdir@ has the same problem. Instead, we should use our @SRCDIR@ configuration variable, which is canonicalized.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 487361773d..fa975a2814 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2129,6 +2129,7 @@ if test "x$SRCDIR" = "x"; then
SRCDIR=$(cd "$srcdir"; pwd)
fi
AH_TEMPLATE([SRCDIR],[tor's sourcedir directory])
+AC_SUBST(SRCDIR)
AC_DEFINE_UNQUOTED(SRCDIR,"$SRCDIR")
if test "x$CONFDIR" = "x"; then