summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-10-17 16:04:39 +1000
committerteor <teor@torproject.org>2019-10-18 17:15:34 +1000
commitf59c4a094090e0c5cfe4c5a7aa3ffdc357fc95f0 (patch)
treebc35b2a384b8028c3c197a1d562f4e1dfd7f3c56 /configure.ac
parent5ff99901d29fe0645edf5f5cfc1d15e2ca6f4686 (diff)
downloadtor-f59c4a094090e0c5cfe4c5a7aa3ffdc357fc95f0.tar.gz
tor-f59c4a094090e0c5cfe4c5a7aa3ffdc357fc95f0.zip
configure: Interpret --disable-module-dirauth=no correctly
Fixes bug 32134; bugfix on 0.3.4.1-alpha.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0540ffb40c..11d49df458 100644
--- a/configure.ac
+++ b/configure.ac
@@ -258,11 +258,11 @@ m4_define(MODULES, dirauth)
dnl Directory Authority module.
AC_ARG_ENABLE([module-dirauth],
AS_HELP_STRING([--disable-module-dirauth],
- [Build tor without the Directory Authority module: tor can not run as a directory authority or bridge authority]),
- [], dnl Action if-given
- AC_DEFINE([HAVE_MODULE_DIRAUTH], [1],
- [Compile with Directory Authority feature support]))
-AM_CONDITIONAL(BUILD_MODULE_DIRAUTH, [test "x$enable_module_dirauth" != "xno"])
+ [Build tor without the Directory Authority module: tor can not run as a directory authority or bridge authority]))
+AM_CONDITIONAL(BUILD_MODULE_DIRAUTH,[test "x$enable_module_dirauth" != "xno"])
+AM_COND_IF(BUILD_MODULE_DIRAUTH,
+ AC_DEFINE([HAVE_MODULE_DIRAUTH], [1],
+ [Compile with Directory Authority feature support]))
dnl Helper variables.
TOR_MODULES_ALL_ENABLED=