summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2020-05-06 16:47:03 -0400
committerNick Mathewson <nickm@torproject.org>2020-05-06 16:47:03 -0400
commit82effefb69defc757ed2f576d40badbd8460f757 (patch)
tree667235b03238dd6074d8a7836b71a1a06803a63c /configure.ac
parent42dfcd0ae3f7a872a781452c289b4e47c494d122 (diff)
parentfecc5fd38d80093a9c189eece4acd41c35cd36c6 (diff)
downloadtor-82effefb69defc757ed2f576d40badbd8460f757.tar.gz
tor-82effefb69defc757ed2f576d40badbd8460f757.zip
Merge branch 'maint-0.4.3'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e2645a11e..4cb64f6230 100644
--- a/configure.ac
+++ b/configure.ac
@@ -434,6 +434,22 @@ if test "$tor_cv_c_c99_designated_init" != "yes"; then
AC_MSG_ERROR([Your compiler doesn't support c99 designated initializers. This is required as of Tor 0.2.6.x])
fi
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -Werror"
+AC_CACHE_CHECK([for __attribute__((fallthrough))],
+ tor_cv_c_attr_fallthrough,
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([extern int x; void fn(void) ;],
+ [[ switch (x) { case 1: fn(); __attribute__((fallthrough));
+ case 2: fn(); break; } ]])],
+ [tor_cv_c_attr_fallthrough=yes],
+ [tor_cv_c_attr_fallthrough=no] )])
+CFLAGS="$saved_CFLAGS"
+
+if test "$tor_cv_c_attr_fallthrough" == "yes"; then
+ AC_DEFINE(HAVE_ATTR_FALLTHROUGH, [1], [defined if we have the fallthrough attribute.])
+fi
+
TORUSER=_tor
AC_ARG_WITH(tor-user,
AS_HELP_STRING(--with-tor-user=NAME, [specify username for tor daemon]),