summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2020-03-31 08:21:12 -0400
committerteor <teor@torproject.org>2020-04-01 23:02:24 +1000
commit6c5c503a4ca892380a7ad26b8355faae6680bd47 (patch)
tree048fa1d92784f87e1069c160eb629b45cc944990 /configure.ac
parent42e56f5bacc6ead39bfef790c6f9ca9be0419739 (diff)
downloadtor-6c5c503a4ca892380a7ad26b8355faae6680bd47.tar.gz
tor-6c5c503a4ca892380a7ad26b8355faae6680bd47.zip
configure: Fix enabled module variable expansion
Fixes #33646 Signed-off-by: David Goulet <dgoulet@torproject.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b4bea277f6..27cfda1be3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2665,7 +2665,7 @@ PPRINT_SUBTITLE([Modules])
m4_foreach_w([mname], MODULES,
[
- test "xenable_module_mname" != "xno" && value=1 || value=0
+ AM_COND_IF(m4_join([], [BUILD_MODULE_], m4_toupper([]mname[])), value=1, value=0)
PPRINT_PROP_BOOL([mname (--disable-module-mname)], $value)
]
)