summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-11-06 14:02:22 +1000
committerteor <teor@torproject.org>2019-11-06 14:08:07 +1000
commitbf5b17d8bbcc55fbae67b5c45077b9dcba697048 (patch)
treead5ea905342ffe934ddde42fb68f3ac74dedbb9d /configure.ac
parent9ca25f3a68374ca4787b4eaa8bf4fb3365061d26 (diff)
downloadtor-bf5b17d8bbcc55fbae67b5c45077b9dcba697048.tar.gz
tor-bf5b17d8bbcc55fbae67b5c45077b9dcba697048.zip
configure: Fix variable name typos
The "if-present" clause of AC_ARG_ENABLE() sets enable_{lzma,zstd}, so we don't need to set it. The "if-not-present" clause needs to set enable_{lzma,zstd}, rather than just {lzma,zstd}. The rest of the script only ever checks for enable_{lzma,zstd} = no, so these changes do not actually change the behaviour of configure. Fixes bug 32401.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 487361773d..e949aca9db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1080,10 +1080,10 @@ dnl Where we do we find lzma?
AC_ARG_ENABLE(lzma,
AS_HELP_STRING(--enable-lzma, [enable support for the LZMA compression scheme.]),
[case "${enableval}" in
- "yes") lzma=true ;;
- "no") lzma=false ;;
+ "yes") ;;
+ "no") ;;
* ) AC_MSG_ERROR(bad value for --enable-lzma) ;;
- esac], [lzma=auto])
+ esac], [enable_lzma=auto])
if test "x$enable_lzma" = "xno"; then
have_lzma=no;
@@ -1112,10 +1112,10 @@ dnl Where we do we find zstd?
AC_ARG_ENABLE(zstd,
AS_HELP_STRING(--enable-zstd, [enable support for the Zstandard compression scheme.]),
[case "${enableval}" in
- "yes") zstd=true ;;
- "no") zstd=false ;;
+ "yes") ;;
+ "no") ;;
* ) AC_MSG_ERROR(bad value for --enable-zstd) ;;
- esac], [zstd=auto])
+ esac], [enable_zstd=auto])
if test "x$enable_zstd" = "xno"; then
have_zstd=no;