summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Kadianakis <desnacked@riseup.net>2019-06-11 14:12:22 +0300
committerGeorge Kadianakis <desnacked@riseup.net>2019-06-11 14:12:22 +0300
commita7986755eee19b948c46f0b43ad3f6174071bd79 (patch)
treeabec4b5de8e2edd5678543a2fcda0c298ab0371a /configure.ac
parente5ad6fb09298eff0bf8ebf0c3729602b91c3d9df (diff)
parent66eae4afffb35afe891ec14a3389a484ecb7b373 (diff)
downloadtor-a7986755eee19b948c46f0b43ad3f6174071bd79.tar.gz
tor-a7986755eee19b948c46f0b43ad3f6174071bd79.zip
Merge branch 'tor-github/pr/1060'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04ea2145c2..75ca03d7d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1188,6 +1188,17 @@ m4_ifdef([AS_VAR_IF],[
TOR_CHECK_LDFLAGS(-pie, "$all_ldflags_for_check", "$all_libs_for_check")
fi
TOR_TRY_COMPILE_WITH_CFLAGS(-fwrapv, also_link, CFLAGS_FWRAPV="-fwrapv", true)
+
+ AC_MSG_CHECKING([whether we can run hardened binaries])
+ AC_RUN_IFELSE([AC_LANG_PROGRAM([], [return 0;])],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])
+ AC_MSG_ERROR([dnl
+ We can link with compiler hardening options, but we can't run with them.
+ That's a bad sign! If you must, you can pass --disable-gcc-hardening to
+ configure, but it would be better to figure out what the underlying problem
+ is.])],
+ [AC_MSG_RESULT([cross])])
fi
if test "$fragile_hardening" = "yes"; then