summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-01-12 09:49:52 -0500
committerNick Mathewson <nickm@torproject.org>2015-01-12 10:03:06 -0500
commitb0c32106b3559b4ee9fabfb1a49e2e328c850305 (patch)
treecde29b97c31f3b355e9b633492a7fcf269764bca /configure.ac
parent8df35a0c882d34415b1505a130cbd7a5c0424035 (diff)
downloadtor-b0c32106b3559b4ee9fabfb1a49e2e328c850305.tar.gz
tor-b0c32106b3559b4ee9fabfb1a49e2e328c850305.zip
If libsystemd-daemon.pc is not found, look for libsystemd
(Thanks to toralf for noting that the build was broken, and to Sebastian for telling me that my fix still wasn't right.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b89ae8d7c3..c254725c60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,6 +126,13 @@ else
[libsystemd-daemon],
have_systemd=yes,
have_systemd=no)
+ if test x$have_systemd=xno; then
+ AC_MSG_NOTICE([Okay, checking for systemd a different way...])
+ PKG_CHECK_MODULES(SYSTEMD,
+ [libsystemd],
+ have_systemd=yes,
+ have_systemd=no)
+ fi
fi
if test x$have_systemd = xyes; then