summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChelsea Holland Komlo <me@chelseakomlo.com>2017-10-12 17:29:51 -0400
committerNick Mathewson <nickm@torproject.org>2017-10-27 10:02:08 -0400
commit0c4d535972bcf14fec0b65c82359db28b0cc0091 (patch)
treef7ab90fcf661b29bc1e80cfa16c21832d8eae3db /configure.ac
parentbe583a34a3815c2c10e86094ab0610e4b7f9c869 (diff)
downloadtor-0c4d535972bcf14fec0b65c82359db28b0cc0091.tar.gz
tor-0c4d535972bcf14fec0b65c82359db28b0cc0091.zip
refactor build infrastructure for single rust binary
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e20a6b9904..c0d454ae45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -439,16 +439,12 @@ if test "x$enable_rust" = "xyes"; then
dnl For now both MSVC and MinGW rust libraries will output static libs with
dnl the MSVC naming convention.
if test "$bwin32" = "true"; then
- TOR_RUST_UTIL_STATIC_NAME=tor_util.lib
- TOR_RUST_PROTOVER_STATIC_NAME=libprotover.lib
+ TOR_RUST_STATIC_NAME=tor_rust.lib
else
- TOR_RUST_UTIL_STATIC_NAME=libtor_util.a
- TOR_RUST_PROTOVER_STATIC_NAME=libprotover.a
+ TOR_RUST_STATIC_NAME=libtor_rust.a
fi
- AC_SUBST(TOR_RUST_UTIL_STATIC_NAME)
- AC_SUBST(TOR_RUST_PROTOVER_STATIC_NAME)
- AC_SUBST(TOR_RUST_C_STRING_STATIC_NAME)
+ AC_SUBST(TOR_RUST_STATIC_NAME)
AC_SUBST(CARGO_ONLINE)
AC_SUBST(RUST_DL)